/**
* filename extension
* 时间限制:C/C++语言 1000MS;其他语言 3000MS
* 内存限制:C/C++语言 65536KB;其他语言 589824KB
* 题目描述:
* Please create a function to extract the filename extension from the given path,
* return the extracted filename extension or null if none.
* 输入
* 输入数据为一个文件路径
* 输出
* 对于每个测试实例,要求输出对应的filename extension
* <p>
* 样例输入
* Abc/file.txt
* 样例输出
* txt
*/
import java.util.Scanner;
public class Main { public static void main(String[] arg) {
Scanner scan = new Scanner(System.in); while (scan.hasNext()) {
String filepath = scan.nextLine(); int index = filepath.lastIndexOf(".");
System.out.println(filepath.substring(index + 1));
}
scan.close();
}
/**
* 统计字符
* 时间限制:C/C++语言 1000MS;其他语言 3000MS
* 内存限制:C/C++语言 65536KB;其他语言 589824KB
* 题目描述:
* 给定一个英文字符串,请写一段代码找出这个字符串中首先出现三次的那个英文字符。
* 输入
* "qywyery23tdd"
* 输出
* y
* <p>
* 样例输入
* Have you ever gone shopping and
*/
import java.util.Scanner;
public class Main { public static void main(String[] arg) {
Scanner scan = new Scanner(System.in); while (scan.hasNext()) {
String word = scan.nextLine(); if (word == null || word.length() < 3) {
System.out.println("");
} int[] count = new int[256]; boolean flag = false; for (int i = 0, len = word.length(); i < len; i++) { if (++count[word.charAt(i)] == 3) { char ch = word.charAt(i); if (ch >= 'a' && ch <= 'z' || ch >= 'A' && ch <= 'Z') {
System.out.println(ch);
flag = true; break;
}
}
} if (!flag) {
System.out.println("");
}
}
scan.close();
}
}